The following packages are BROKEN: linux-headers-generic linux-image-generic linux-restricted-modules-2.6.17-11-generic The following packages will be upgraded: fglrx-control linux-generic linux-restricted-modules-common linux-restricted-modules-generic linux-source xorg-driver-fglrx 8 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded. Need to get 17.3MB of archives. After unpacking 20.9MB will be used. The following packages have unmet dependencies: linux-headers-generic: Depends: linux-headers-2.6.17-11-generic which is a virtual package. linux-image-generic: Depends: linux-image-2.6.17-11-generic which is a virtual package. linux-restricted-modules-2.6.17-11-generic: Depends: linux-image-2.6.17-11-generic which is a virtual package. Resolving dependencies... The following actions will resolve these dependencies: Keep the following packages at their current version: linux-headers-generic [2.6.17.10 (edgy, now)] linux-image-generic [2.6.17.10 (edgy, now)] linux-restricted-modules-2.6.17-11-generic [Not Installed] linux-restricted-modules-generic [2.6.17.10 (edgy, now)] Score is -91 Accept this solution? [Y/n/q/?]