ou might want to run `apt-get -f install' to correct these. The following packages have unmet dependencies: libc6-dev: Depends: libc6 (= 2.3.6.ds1-13) but 2.3.2.ds1-22sarge6 is installed libdb4.4: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge6 is installed libgdbm3: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge6 is installed libhtml-parser-perl: Depends: perlapi-5.8.8 Depends: perl (>= 5.8.8-6) but 5.8.4-8sarge5 is installed Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge6 is installed locales: Depends: glibc-2.3.6.ds1-1 perl-modules: Depends: perl (>= 5.8.8-1) but 5.8.4-8sarge5 is installed E: Unmet dependencies. Try using -f. apt-get -f install Reading Package Lists... Done Building Dependency Tree... Done Correcting dependencies... Done The following extra packages will be installed: libc6 libperl5.8 perl perl-base Suggested packages: glibc-doc libterm-readline-gnu-perl libterm-readline-perl-perl Recommended packages: perl-doc The following packages will be upgraded: libc6 libperl5.8 perl perl-base 4 upgraded, 0 newly installed, 0 to remove and 480 not upgraded. 10 not fully installed or removed. Need to get 0B/9561kB of archives. After unpacking 1606kB disk space will be freed. Do you want to continue? [Y/n] (Reading database ... 48274 files and directories currently installed.) Preparing to replace libc6 2.3.2.ds1-22sarge6 (using .../libc6_2.3.6.ds1-13_i386.deb) ... Name Service Switch update in the C Library: pre-installation question. Running services and programs that are using NSS need to be restarted, otherwise they might not be able to do lookup or authentication any more. The installation process is able to restart some services (such as ssh or telnetd), but other programs cannot be restarted automatically. One such program that needs manual stopping and restart after the glibc upgrade by yourself is xdm - because automatic restart might disconnect your active X11 sessions. Known packages that need to be stopped before the glibc upgrade are: xdm kdm gdm postgresql xscreensaver This script detected the following installed services which must be stopped before the upgrade: xdm If you want to interrupt the upgrade now and continue later, please answer No to the question below. Do you want to upgrade glibc now? [Y/n] WARNING: This version of glibc requires that you be running kernel version 2.4.1 or later. Earlier kernels contained bugs that may render the system unusable if a modern version of glibc is installed. dpkg: error processing /var/cache/apt/archives/libc6_2.3.6.ds1-13_i386.deb (--unpack): subprocess pre-installation script returned error exit status 1 Errors were encountered while processing: /var/cache/apt/archives/libc6_2.3.6.ds1-13_i386.deb E: Sub-process /usr/bin/dpkg returned an error code (1)