I want to dial the stuff in [new1] and [new2] ; ; lba: sip.conf - SIP Configuration example for Asterisk ; ; For Asterisk 1.2+ the concept of 'user' is being phased out. ; Use 'peer' for everything. ; Syntax for specifying a SIP device in extensions.conf is ; SIP/devicename where devicename is defined in a section below. ; ; You may also use ; SIP/username@domain to call any SIP user on the Internet ; (Don't forget to enable DNS SRV records if you want to use this) ; ; If you define a SIP proxy as a peer below, you may call ; SIP/proxyhostname/user or SIP/user@proxyhostname ; where the proxyhostname is defined in a section below ; ; Useful CLI commands to check peers/users: ; sip show peers Show all SIP peers (including friends) ; sip show users Show all SIP users (including friends) ; sip show registry Show status of hosts we register with ; ; sip debug Show all SIP messages ; ; reload chan_sip.so Reload configuration file ; Active SIP peers will not be reconfigured ; [general] ; these are what I created to allow entries in extensions.conf context=new1 context=new2 context=default ; Default context for incoming calls ;allowguest=no ; Allow or reject guest calls (default is yes, this can also be set to 'osp' ; if asterisk was compiled with OSP support. ;realm=mydomain.tld ; Realm for digest authentication ; defaults to "asterisk" ; Realms MUST be globally unique according to RFC 3261 ; Set this to your host name or domain name bindport=5060 ; UDP Port to bind to (SIP standard port is 5060) bindaddr=0.0.0.0 ; IP address to bind to (0.0.0.0 binds to all) srvlookup=yes ; Enable DNS SRV lookups on outbound calls ; Note: Asterisk only uses the first host ; in SRV records ; Disabling DNS SRV lookups disables the ; ability to place SIP calls based on domain ; names to some other SIP users on the Internet ;domain=mydomain.tld ; Set default domain for this host ; If configured, Asterisk will only allow ; INVITE and REFER to non-local domains ; Use "sip show domains" to list local domains ;domain=mydomain.tld,mydomain-incoming ; Add domain and configure incoming context ; for external calls to this domain ;domain=1.2.3.4 ; Add IP address as local domain ; You can have several "domain" settings ;allowexternalinvites=no ; Disable INVITE and REFER to non-local domains ; Default is yes ;autodomain=yes ; Turn this on to have Asterisk add local host ; name and local IP to domain list. ;pedantic=yes ; Enable slow, pedantic checking for Pingtel ; and multiline formatted headers for strict ; SIP compatibility (defaults to "no") ;tos=184 ; Set IP QoS to either a keyword or numeric val ;tos=lowdelay ; lowdelay,throughput,reliability,mincost,none ;maxexpiry=3600 ; Max length of incoming registration we allow ;defaultexpiry=120 ; Default length of incoming/outoing registration ;notifymimetype=text/plain ; Allow overriding of mime type in MWI NOTIFY ;checkmwi=10 ; Default time between mailbox checks for peers ;vmexten=voicemail ; dialplan extension to reach mailbox sets the ; Message-Account in the MWI notify message ; defaults to "asterisk" ;videosupport=yes ; Turn on support for SIP video ;recordhistory=yes ; Record SIP history by default ; (see sip history / sip no history) ;disallow=all ; First disallow all codecs ;allow=ulaw ; Allow codecs in order of preference ;allow=ilbc ; ;musicclass=default ; Sets the default music on hold class for all SIP calls ; This may also be set for individual users/peers ;language=en ; Default language setting for all users/peers ; This may also be set for individual users/peers ;relaxdtmf=yes ; Relax dtmf handling ;rtptimeout=60 ; Terminate call if 60 seconds of no RTP activity ; when we're not on hold ;rtpholdtimeout=300 ; Terminate call if 300 seconds of no RTP activity ; when we're on hold (must be > rtptimeout) ;trustrpid = no ; If Remote-Party-ID should be trusted ;sendrpid = yes ; If Remote-Party-ID should be sent ;progressinband=never ; If we should generate in-band ringing always ; use 'never' to never use in-band signalling, even in cases ; where some buggy devices might not render it ;useragent=Asterisk PBX ; Allows you to change the user agent string ;promiscredir = no ; If yes, allows 302 or REDIR to non-local SIP address ; Note that promiscredir when redirects are made to the ; local system will cause loops since SIP is incapable ; of performing a "hairpin" call. ;usereqphone = no ; If yes, ";user=phone" is added to uri that contains ; a valid phone number ;dtmfmode = rfc2833 ; Set default dtmfmode for sending DTMF. Default: rfc2833 ; Other options: ; info : SIP INFO messages ; inband : Inband audio (requires 64 kbit codec -alaw, ulaw) ; auto : Use rfc2833 if offered, inband otherwise ;compactheaders = yes ; send compact sip headers. ;sipdebug = yes ; Turn on SIP debugging by default, from ; the moment the channel loads this configuration ;subscribecontext = default ; Set a specific context for SUBSCRIBE requests ; Useful to limit subscriptions to local extensions ; Settable per peer/user also ;notifyringing = yes ; Notify subscriptions on RINGING state ; ; If regcontext is specified, Asterisk will dynamically create and destroy a ; NoOp priority 1 extension for a given peer who registers or unregisters with ; us. The actual extension is the 'regexten' parameter of the registering ; peer or its name if 'regexten' is not provided. More than one regexten may ; be supplied if they are separated by '&'. Patterns may be used in regexten. ; ;regcontext=sipregistrations ; ; Asterisk can register as a SIP user agent to a SIP proxy (provider) ; Format for the register statement is: ; register => user[:secret[:authuser]]@host[:port][/extension] ; ; If no extension is given, the 's' extension is used. The extension needs to ; be defined in extensions.conf to be able to accept calls from this SIP proxy ; (provider). ; ; host is either a host name defined in DNS or the name of a section defined ; below. ; ; Examples: ; ;register => 1234:password@mysipprovider.com ; ; This will pass incoming calls to the 's' extension ; ; ;register => 2345:password@sip_proxy/1234 register => sanitized ; ; Register 2345 at sip provider 'sip_proxy'. Calls from this provider ; connect to local extension 1234 in extensions.conf, default context, ; unless you configure a [sip_proxy] section below, and configure a ; context. ; Tip 1: Avoid assigning hostname to a sip.conf section like [provider.com] ; Tip 2: Use separate type=peer and type=user sections for SIP providers ; (instead of type=friend) if you have calls in both directions ;registertimeout=20 ; retry registration calls every 20 seconds (default) ;registerattempts=10 ; Number of registration attempts before we give up ; 0 = continue forever, hammering the other server until it ; accepts the registration ; Default is 0 tries, continue forever ;callevents=no ; generate manager events when sip ua performs events (e.g. hold) ;----------------------------------------- NAT SUPPORT ------------------------ ; ; The externip, externhost and localnet settings are used if you use Asterisk ; behind a NAT device to communicate with services on the outside. ; Below lines added by lba after Installfest ; from aah22 sip.nat.conf which is included in sip.conf: ;; externip=69.91.84.176 ; lba externip=larryalk.dyndns.org ; lba ;externip = 200.201.202.203 ; Address that we're going to put in outbound SIP messages ; if we're behind a NAT ; The externip and localnet is used ; when registering and communicating with other proxies ; that we're registered with ;externhost=foo.dyndns.net ; Alternatively you can specify an ; external host, and Asterisk will ; perform DNS queries periodically. Not ; recommended for production ; environments! Use externip instead ;externrefresh=10 ; How often to refresh externhost if ; used ; You may add multiple local networks. A reasonable set of defaults ; are: localnet=192.168.0.0/255.255.255.0 ; lba ;localnet=192.168.0.0/255.255.0.0; All RFC 1918 addresses are local networks ;localnet=10.0.0.0/255.0.0.0 ; Also RFC1918 ;localnet=172.16.0.0/12 ; Another RFC1918 with CIDR notation ;localnet=169.254.0.0/255.255.0.0 ;Zero conf local network ; The nat= setting is used when Asterisk is on a public IP, communicating with ; devices hidden behind a NAT device (broadband router). If you have one-way ; audio problems, you usually have problems with your NAT configuration or your ; firewall's support of SIP+RTP ports. You configure Asterisk choice of RTP ; ports for incoming audio in rtp.conf ; nat=yes ; lba set at A*UG meeting ;nat=no ; Global NAT settings (Affects all peers and users) ; yes = Always ignore info and assume NAT ; no = Use NAT mode only according to RFC3581 ; never = Never attempt NAT mode or RFC3581 support ; route = Assume NAT, don't send rport ; (work around more UNIDEN bugs) ;----------------------------------------- NAT SUPPORT Ends ------------------------ ;rtcachefriends=yes ; Cache realtime friends by adding them to the internal list ; just like friends added from the config file only on a ; as-needed basis? (yes|no) ;rtupdate=yes ; Send registry updates to database using realtime? (yes|no) ; If set to yes, when a SIP UA registers successfully, the ip address, ; the origination port, the registration period, and the username of ; the UA will be set to database via realtime. If not present, defaults to 'yes'. ;rtautoclear=yes ; Auto-Expire friends created on the fly on the same schedule ; as if it had just registered? (yes|no|) ; If set to yes, when the registration expires, the friend will vanish from ; the configuration until requested again. If set to an integer, ; friends expire within this number of seconds instead of the ; registration interval. ;ignoreregexpire=yes ; Enabling this setting has two functions: ; ; For non-realtime peers, when their registration expires, the information ; will _not_ be removed from memory or the Asterisk database; if you attempt ; to place a call to the peer, the existing information will be used in spite ; of it having expired ; ; For realtime peers, when the peer is retrieved from realtime storage, ; the registration information will be used regardless of whether ; it has expired or not; if it expires while the realtime peer is still in ; memory (due to caching or other reasons), the information will not be ; removed from realtime storage ; Incoming INVITE and REFER messages can be matched against a list of 'allowed' ; domains, each of which can direct the call to a specific context if desired. ; By default, all domains are accepted and sent to the default context or the ; context associated with the user/peer placing the call. ; Domains can be specified using: ; domain=[,] ; Examples: ; domain=myasterisk.dom ; domain=customer.com,customer-context ; ; In addition, all the 'default' domains associated with a server should be ; added if incoming request filtering is desired. ; autodomain=yes ; ; To disallow requests for domains not serviced by this server: ; allowexternaldomains=no ; fromdomain=mydomain.tld ; When making outbound SIP INVITEs to ; non-peers, use your primary domain "identity" ; for From: headers instead of just your IP ; address. This is to be polite and ; it may be a mandatory requirement for some ; destinations which do not have a prior ; account relationship with your server. [authentication] ; Global credentials for outbound calls, i.e. when a proxy challenges your ; Asterisk server for authentication. These credentials override ; any credentials in peer/register definition if realm is matched. ; ; This way, Asterisk can authenticate for outbound calls to other ; realms. We match realm on the proxy challenge and pick an set of ; credentials from this list ; Syntax: ; auth = :@ ; auth = #@ ; Example: ;auth=mark:topsecret@digium.com ; ; You may also add auth= statements to [peer] definitions ; Peer auth= override all other authentication settings if we match on realm ;------------------------------------------------------------------------------ ; Users and peers have different settings available. Friends have all settings, ; since a friend is both a peer and a user ;------------------------------------------------------------------------------- ; ; User config options: Peer configuration: ; -------------------- ------------------- ; context context ; permit permit ; deny deny ; secret secret ; md5secret md5secret ; dtmfmode dtmfmode ; canreinvite canreinvite ; nat nat ; callgroup callgroup ; pickupgroup pickupgroup ; language language ; allow allow ; disallow disallow ; insecure insecure ; trustrpid trustrpid ; progressinband progressinband ; promiscredir promiscredir ; useclientcode useclientcode ; accountcode accountcode ; setvar setvar ; callerid callerid ; amaflags amaflags ; call-limit call-limit ; restrictcid restrictcid ; subscribecontext subscribecontext ; mailbox ; username ; template ; fromdomain ; regexten ; fromuser ; host ; port ; qualify ; defaultip ; rtptimeout ; rtpholdtimeout ; sendrpid ; ----------------------------------------------------------------------------------- ; Everything in original sip.conf below this line was deleted at Installfest 2/20/06: ; Lines below are lba specific settings: ; ----------------------------------------------------------------------------------- [telasip-gw] ;context=default context=telasip-out type=peer qualify=200 host=gw3.telasip.com username=sanitized secret=sanitized insecure=very canreinvite=no callerid="Larry Alkoff" <5123011414> nat=yes [120] context=default username=120 type=friend qualify=yes insecure=very host=dynamic canreinvite=no nat=no ; Above lines created at Installfest. ; lba: extensions.conf - configure all inbound & outbound calls & dialplans here: ; ; Static extension configuration file, used by ; the pbx_config module. This is where you configure all your ; inbound and outbound calls in Asterisk. ; ; This configuration file is reloaded ; - With the "extensions reload" command in the CLI ; - With the "reload" command (that reloads everything) in the CLI ; ; The "General" category is for certain variables. ; [general] ; ; If static is set to no, or omitted, then the pbx_config will rewrite ; this file when extensions are modified. Remember that all comments ; made in the file will be lost when that happens. ; ; XXX Not yet implemented XXX ; static=yes ; ; if static=yes and writeprotect=no, you can save dialplan by ; CLI command 'save dialplan' too ; writeprotect=no ; ; If autofallthrough is set, then if an extension runs out of ; things to do, it will terminate the call with BUSY, CONGESTION ; or HANGUP depending on Asterisk's best guess (strongly recommended). ; ; If autofallthrough is not set, then if an extension runs out of ; things to do, asterisk will wait for a new extension to be dialed ; (this is the original behavior of Asterisk 1.0 and earlier). ; autofallthrough=yes ; ; If clearglobalvars is set, global variables will be cleared ; and reparsed on an extensions reload, or Asterisk reload. ; ; If clearglobalvars is not set, then global variables will persist ; through reloads, and even if deleted from the extensions.conf or ; one if its included files, will remain set to the previous value. ; clearglobalvars=no ; ; If priorityjumping is set to 'yes', then applications that support ; 'jumping' to a different priority based on the result of their operations ; will do so (this is backwards compatible behavior with pre-1.2 releases ; of Asterisk). Individual applications can also be requested to do this ; by passing a 'j' option in their arguments. ; priorityjumping=no ; ; You can include other config files, use the #include command ; (without the ';'). Note that this is different from the "include" command ; that includes contexts within other contexts. The #include command works ; in all asterisk configuration files. ;#include "filename.conf" ; ------------------------ Globals ------------------------------ ; The "Globals" category contains global variables that can be referenced ; in the dialplan with ${VARIABLE} or ${ENV(VARIABLE)} for Environmental ; variables, ; ${${VARIABLE}} or ${text${VARIABLE}} or any hybrid ; [globals] CONSOLE=Console/dsp ; Console interface for demo ;CONSOLE=Zap/1 ;CONSOLE=Phone/phone0 IAXINFO=guest ; IAXtel username/password ;IAXINFO=myuser:mypass TRUNK=Zap/g2 ; Trunk interface ; ; Note the 'g2' in the TRUNK variable above. It specifies which group (defined ; in zapata.conf) to dial, i.e. group 2, and how to choose a channel to use in ; the specified group. The four possible options are: ; ; g: select the lowest-numbered non-busy Zap channel ; (aka. ascending sequential hunt group). ; G: select the highest-numbered non-busy Zap channel ; (aka. descending sequential hunt group). ; r: use a round-robin search, starting at the next highest channel than last ; time (aka. ascending rotary hunt group). ; R: use a round-robin search, starting at the next lowest channel than last ; time (aka. descending rotary hunt group). ; TRUNKMSD=1 ; MSD digits to strip (usually 1 or 0) ;TRUNK=IAX2/user:pass@provider ; ------------------------ Globals End ------------------------------ ; ------------------------ lba Tutorial ----------------------------- ; ; Any category other than "General" and "Globals" represent ; extension contexts, which are collections of extensions. ; ; Extension names may be numbers, letters, or combinations ; thereof. If an extension name is prefixed by a '_' ; character, it is interpreted as a pattern rather than a ; literal. In patterns, some characters have special meanings: ; ; X - any digit from 0-9 ; Z - any digit from 1-9 ; N - any digit from 2-9 ; [1235-9] - any digit in the brackets (in this example, 1,2,3,5,6,7,8,9) ; . - wildcard, matches anything remaining (e.g. _9011. matches ; anything starting with 9011 excluding 9011 itself) ; ! - wildcard, causes the matching process to complete as soon as ; it can unambiguously determine that no other matches are possible ; ; For example the extension _NXXXXXX would match normal 7 digit dialings, ; while _1NXXNXXXXXX would represent an area code plus phone number ; preceeded by a one. ; ; Each step of an extension is ordered by priority, which must ; always start with 1 to be considered a valid extension. The priority ; "next" or "n" means the previous priority plus one, regardless of whether ; the previous priority was associated with the current extension or not. ; The priority "same" or "s" means the same as the previously specified ; priority, again regardless of whether the previous entry was for the ; same extension. Priorities may be immediately followed by a plus sign ; and another integer to add that amount (most useful with 's' or 'n'). ; Priorities may then also have an alias, or label, in ; parenthesis after their name which can be used in goto situations ; ; Contexts contain several lines, one for each step of each ; extension, which can take one of two forms as listed below, ; with the first form being preferred. One may include another ; context in the current one as well, optionally with a ; date and time. Included contexts are included in the order ; they are listed. ; ;[context] ;exten => someexten,priority[+offset][(alias)],application(arg1,arg2,...) ;exten => someexten,priority[+offset][(alias)],application,arg1|arg2... ; lba Dial() application: ; exten => _91.,2,Dial(SIP/${EXTEN:1}@telasip-gw) ; dest# ; priority ; Dial() command w/4 arguments: (2 & 3 may be omitted) ; 1 remote resource/channel number eg: SIP/${EXTEN:1} ; 2 timeout (not incl here) ; 3 option string (not incl here) ; 4 url or POTS number ; ; ------------------------ lba Tutorial Ends ----------------------------- ; ; Timing list for includes is ; ;